How to interact with DXtrust directly form your browser

Whats DXtrust?

Step 1

Open remix online solidity editor →
Go to the plugin manager on the left of the app and activate the Solidity Compiler and Deploy and run trasactions plugins.

Step 2

Create a file and import the Decentralized Autonomous Trust contract used for DXtrust.
To create a file click in the plus icon in the contracts section.

Name the file DXtrust.sol and copy the contract code from the smart contract used as implementation form DecentralizedAutonomousTrust | 0x845856776D110a200Cf41f35C9428C938e72E604

Step 3

Compile the DXtrust.sol contract by going to the “Compiler” plugin and click in compile.

Step 4

Interact with the contract in the “Deploy and Run transactions”.
Select the “Injected Web3” option in Environment, and connect to mainnet, select the DecentralizedAutonomousTrust.sol contract and in the input “atAddress” paste the DXtrust proxy address 0xa1d65E8fB6e87b60FECCBc582F7f97804B725521.

After you lick in the “atAddress” button you will be able to interact with the DecentralizedAutonomousTrust .solcontract by scrolling to the bottom of the plugin and expanding the smart contract functions.

The blue buttons are view functions, the orange ones are functions to be executed with transactions and the red ones are functions to be executed with transactions that accepts ETH.


Was anyone successful in compiling and running the contract? I guess I’m making a mistake ^^

Are you setting the right ABI and address?
Take the ABI from

And use the contract at address 0xa1d65E8fB6e87b60FECCBc582F7f97804B725521

All this connected to mainnet through web3 injected provider.

I’m new to this:) Setting right ABI is I guess basic knowledge that’s why it wasn’t mentioned in the tutorial. How do set it up? Thanks in advance.

Sorry, I meant the source code,the one you have to use when you create the contract that you get from

Is the step 2

Yes, I followed your tutorial and basically I have two things which don’t work. First, after compiling I don’t get the green “verified/working” check-sign and after pressing the “at address” I don’t get this menu of the deployed contract.

Do you have the right compiler version selected? 0.5.17?

Yes. I tried it again but no results :confused:

Good news, the contract proxy has been verified in Etherscan, which means that you can interact with all public read/write functions in the contract code section